古いperlについて、セキュリティ対策のために順次バージョンアップしています。

古いperlについて、セキュリティ対策のために順次バージョンアップしています。

バージョンアップ後
日本語ライブラリ jcode.pl を利用しているcgiはエラーをだします。

回避策は次の通り、

jacode.pl をサーバーでjcode.pl があるcgiフォルダに転送して、
利用cgiの該当部分を修正する。

参考記事
https://shade-search.com/sts/term/term.php?noform=paVJ5IlrAN&sort=menu

cgiの中で、つぎのような記述の場所を
require ‘./jcode.pl’; #日本語コード変換

require ‘./jacode.pl’; #日本語コード変換

に変更

jacode.pl はここからダウンロードできます。
https://metacpan.org/pod/release/INA/jacode-2.13.4.18/lib/jacode.pl
左端メニューのtool のところにダウンロードリンク
ダウンロードしたファイルを解凍して、/lib に入っているjacode.plを利用

タイトルとURLをコピーしました